GameSalad

GameSalad

Banner Saladsolutions

Salad Solutions is a compilation of educational resources developed by the GameSalad team. Resources include: webinar videos, Question of the Week answers, and Cookbook highlights.

Hello everyone!

Recently, Apple released Xcode version 4.3, and so we wanted to take a moment to touch on what this means for our users.

First and foremost, we'd like to confirm that based on our internal testing, Xcode 4.3 appears to work perfectly well with the GameSalad Creator. However, you will need to download a few components which are not installed by default. Below we've provided some simple instructions on how to go about this, as well as a list of which components you'll need.

For those of you who are still using Xcode 4.2, or do not meet the minimum system requirements to install Xcode 4.3 (Mac OS X 10.7.3 or later), know that 4.2 continues to be the officially supported version for GameSalad Creator and its associated applications and services (such as GS Viewer and publishing). On a related point, for those of you who are using an Xcode version prior to 4.2, we recommend updating to version 4.2 as soon as possible, as older versions will limit your ability to successfully access some GameSalad features.

Thanks for reading, and happy developing!

Steps for installing Xcode 4.3 components:

To access the Downloads menu, click 'Xcode' in the menu bar, then 'preferences…', click the 'Downloads' button, and finally select the 'Components' tab. There you should find the required supplementary install options:

• iOS 4.3 Simulator
This package includes the complete iOS Simulator for this previous version of iOS. If your app intends to support this version of iOS, it is highly recommended that you download this package to aid in your development and debugging.

• iOS 4.0 - 4.1 Device Debugging Support
This package includes information and symbols that Xcode needs for debugging your app on iOS devices running versions of iOS prior to iOS 4.2. If you intend to debug your app on a device running one of these versions of iOS you should install this package.

• iOS 3.0 - 3.2.2 Device Debugging Support
This package includes information and symbols that Xcode needs for debugging your app on iOS devices running versions of iOS prior to iOS 4.2. If you intend to debug your app on a device running one of these versions of iOS you should install this package